.
 
.

ÜberwareTM

View Forum Thread

Anyone can view the forums, but you need to log in in order to post messages.

> Forum Home > Support > Nuke Rendering Help

  Wed, 29/Aug/2018 7:12 AM
Paul
2 Posts
Hi,
We have been trying to get Nuke to render on Smedge for months now with no luck. Have a Mac Os network setup. 2x floating application licenses and 4x floating render licenses. We can't get any of them to work.
We have been testing on one machine to try and get it working and it just sets the packet complete as soon as it has started. Log report below.
Has anyone managed to get Nuke to render on Smedge? Any ideas on how we can get this to work?
Thanks.

Smedge 2018 Update 1 and Nuke 11.2v03.

18.08.29 12:01:13.647 [ Info ] <0x7FFF9E70E380: Main Thread> Requested to start job 'Farm_Test_V01 0038' (Nuke) with 12 CPUs after 0.0 seconds
18.08.29 12:01:13.647 [ Status ] <0x70000F53E000: JobThread> Executing Work Farm_Test_V01: 0038
18.08.29 12:01:13.650 [ Info ] <0x70000F53E000: JobThread> ProcessJob listening for output on: BDHMissjones.local:51290
18.08.29 12:01:13.651 [ Info ] <0x70000F644000: ProcessWatcher> Saving output for Job '0038' in file: ~/Library/Smedge/Logs/SmedgeEngine/WorkLogs/4ccd3e5a-c46a-4b5d-8ac1-bc4473812c07/Farm_Test_V01-0038.log
18.08.29 12:01:13.655 [ Info ] <0x70000F644000: ProcessWatcher> OptionsFile Saved: ~/Library/Smedge/SmedgeEngine/FileServer.ini
18.08.29 12:01:13.655 [ Info ] <0x70000F644000: ProcessWatcher> Share {ed004f03-6f5e-4194-9cb0-10d855d419b8}: ~/Library/Smedge/Logs/SmedgeEngine/WorkLogs/4ccd3e5a-c46a-4b5d-8ac1-bc4473812c07/Farm_Test_V01-0038.log
18.08.29 12:01:13.655 [ Info ] <0x70000F53E000: JobThread> Trying to execute: /Applications/Nuke11.2v3/Nuke11.2v3.app/Contents/MacOS/Nuke11.2v3 -x -m 12 -V -- /tmp/smedge/LocalCopies/4ccd3e5a-c46a-4b5d-8ac1-bc4473812c07/Farm_Test_V01.nk 38,38
18.08.29 12:01:13.774 [ Info ] <0x70000F644000: ProcessWatcher> Engine requests Error Text Processing (beginning of line)
18.08.29 12:01:13.804 [ Warning ] <0x70000F53E000: JobThread> Process returned an unsuccessful exit code: 100
18.08.29 12:01:13.804 [ Info ] <0x70000F53E000: JobThread> Not checking frames because result check shows an unfinished or failed work unit
18.08.29 12:01:13.804 [ Info ] <0x70000F53E000: JobThread> ProcessJob::Execute result: In Progress(processor usage 000:00:00:00.137 - min 0)
18.08.29 12:01:13.805 [ Status ] <0x70000F53E000: JobThread> Finished Work Farm_Test_V01: 0038 with status Unsuccessful
   
  Thu, 30/Aug/2018 2:24 PM
Robin
1136 Posts
Hello

The log snippet you posted shows that the Nuke process is returning an unsuccessful exit code when the render is started. It's hard to know what the failure is from the code alone. Do you get any captured output from the render? If you can post that or send it to , that may help.

Another thing to test is to copy the Smedge generated command line into a Terminal window on the rendering machine. If Nuke is popping up a message box or notification of some kind (perhaps a license error), we may not be able to see it when you render in Smedge, but should be able to see it if you start the render process manually.

You can copy the command line from the History.log or from the top of the captured output from a render. I know several other users are running Nuke, and the most likely issue is some kind of configuration issue with licensing of Nuke or configuration of paths or something. Especially if you are using daemons or a different user account for running Smedge than you use for logging into the workstation consoles.

Thank you,
-robin
   
  Thu, 03/Jan/2019 12:07 PM
Paul
2 Posts
Hi Robin,

Back again, still haven't been able to solve rendering nuke via Smedge. I copied the Smedge generated command line into a Terminal window and everything rendered fine. I just can't get it to render from Smedge. History log below.
We have floating licences for Nuke, not sure if this could be the issue? Would be good if we could pick this up again.

Thanks.

19.01.03 16:54:34.601 [ Info ] <0x7FFF8956D380: Main Thread> Requested to start job 'Farm_Test_V01 0069' (Nuke) with 16 CPUs after 0.0 seconds
19.01.03 16:54:34.602 [ Status ] <0x700003D92000: JobThread> Executing Work Farm_Test_V01: 0069
19.01.03 16:54:34.606 [ Info ] <0x700003D92000: JobThread> ProcessJob listening for output on: BDHMrsDoyle.local:61543
19.01.03 16:54:34.607 [ Info ] <0x700003E98000: ProcessWatcher> Saving output for Job '0069' in file: ~/Library/Smedge/Logs/SmedgeEngine/WorkLogs/2c569835-a36e-4faa-9bb9-0f07a102a525/Farm_Test_V01-0069.log
19.01.03 16:54:34.607 [ Info ] <0x700003E98000: ProcessWatcher> OptionsFile Saved: ~/Library/Smedge/SmedgeEngine/FileServer.ini
19.01.03 16:54:34.607 [ Info ] <0x700003E98000: ProcessWatcher> Share {cdfdfe53-f278-4fbd-9c2c-f5a90f6ec308}: ~/Library/Smedge/Logs/SmedgeEngine/WorkLogs/2c569835-a36e-4faa-9bb9-0f07a102a525/Farm_Test_V01-0069.log
19.01.03 16:54:34.608 [ Info ] <0x700003D92000: JobThread> Trying to execute: /Applications/Nuke11.3v1/Nuke11.3v1.app/Contents/MacOS/Nuke11.3v1 -x -i -m 16 -V -- /tmp/smedge/LocalCopies/2c569835-a36e-4faa-9bb9-0f07a102a525/Farm_Test_V01.nk 69,69
19.01.03 16:54:34.672 [ Info ] <0x700003E98000: ProcessWatcher> Engine requests Error Text Processing (beginning of line)
19.01.03 16:54:34.673 [ Info ] <0x700003D92000: JobThread> Job requests not to check exit code
19.01.03 16:54:34.673 [ Info ] <0x700003D92000: JobThread> Engine requests Image Checking (will not delete files that fail)
19.01.03 16:54:34.673 [ Info ] <0x700003D92000: JobThread> ProcessJob::Execute result: In Progress(processor usage 000:00:00:00.060 - min 0)
19.01.03 16:54:34.673 [ Status ] <0x700003D92000: JobThread> Finished Work Farm_Test_V01: 0069 with status Complete
   
  Thu, 10/Jan/2019 5:58 PM
Robin
1136 Posts
Please contact me directly at so I can remote connect and take a look. Thank you,
-robin
   
Page 1 of 1

.
.
.
.
©2000 - 2013 Überware. All rights reserved